Ubuntu 7.10 Gutsy 에서 VirtualBox 의 USB 인식 문제와 해결책

VirtualBox 는 무료에다 빠르고 설치도 비교적 쉽다. 그런데 요놈은 USB 설정이 간단치가 않다. 내 주변인들도 나에게 평소 VirtualBox 의 USB 에 대한 질문을 수차례 하였기에 이번에는 글로 작성한다. 이 글의 목표는 Ubuntu 7.10 Gutsy 에서 VirtualBox가 USB 를 인식하게 만드는 것이다.

1. VirtualBox 버전 확인하기
USB 사용을 위해서는 PUEL 버전을 설치해야 한다. 이를 위해 사용중인 VirtualBox 의 버전을 확인한다. VirtualBox 는 PUEL 버전과 OSE(Open Source Edition) 버전으로 나누어진다. 두 버전의 근본적인 차이는 적용된 라이센스이지만 사용자 입장에서의 차이는 PUEL 버전은 간단한 사용자 등록(이름과 이메일 정도) 후 모든 기능을 제공하는데 반해 OSE 버전은 몇가지 제한을 가지고 있다는 것이다. 그 대표적인 예가 USB 불가 이다. 나머지 제한은 나도 잘 모르겠다.

2. usbfs 인식 되었는지 확인하기
PUEL 버전을 설치했다고 바로 되면 좋겠지만 현재 우분투 버전은 그렇지가 않다. 우선 VirtualBox 에서 메뉴에서 Machine -> Settings 를 열어 보자. 그럼 아래와 같은 그림을 볼 수 있다.

usbfs 마운트 전

VirtualBox -> Machine -> Settings


빨간색 박스안에 USB 가 있다면 섹션 3(마우스 휠 세번 내리세요)으로 넘어가고 없다면 다음과 같이 한다.
sudo mount -t usbfs /sys/bus/usb /proc/bus/usb/

그리고 나서 VirtualBox 를 껏다 다시 실행하면 다음과 같이 USB 메뉴가 생기는지 확인한다.(만약 USB 메뉴가 안나오면 내가 아래 제시할 해결책이 소용없으므로 다른 방법을 찾아 보기 바란다.)

사용자 삽입 이미지

usbfs 를 인식한 VirtualBox

3.  fstab 에 usbfs 추가하기(해결책)
(섹션 2를 거쳐 여기 까지 왔다면 문제는 아래 방법으로 해결될 확률이 아주 높다고 생각한다.)
USB 인식 문제를 해결하기 위해서는 /proc/bus/usb 안의 파일들을 VirtualBox 를 구동하는 사용자 권한으로 쓰기 가능하게 해야 한다. 내가 찾은 글들에서는 vboxuser group 으로 쓰기 권한을 주는 것으로 써 놓았는데 내 생각에는 plugdev 로 하는게 정석인 것 같아 plugdev 의 gid, 즉 46으로 하여 /etc/fstab 에 다음 라인을 추가했다.

none            /proc/bus/usb   usbfs   devgid=46,devmode=664 0 0

위와 같이 하고 재부팅을 하거나 재부팅이 귀찮다면 umount /proc/bus/usb && mount /proc/bus/usb 을 하고 VirtualBox 를 재시작 해보자. 그리고 USB 를 꽂으면 짜잔 하고 작은 풍선 도움말이 반겨줄 것이다!

References

덧붙임. 혹시나 빼먹은 내용이 있을지 모르니 제가 쓴 글대로 해서 안되는 분들도 있으시면 리플 부탁 드립니다.


Ubuntu 7.10 Gutsy 에서 VirtualBox 인터넷 뱅킹 하다가 멈추는 문제 와 해결책

최근 삽질신이 어깨에 올라 앉았는지 갑자기 젠투를 밀고 우분투를 설치하고 싶어졌다(1년에 몇번씩 배포판 마다 왔다리 갔다리 한다). 마침 당분간은 약간 여유가 있는 터라 우분투 로 고고!

그리고 우분투 7.10 Gutsy AMD64 버전을 간편하게 다음 미러(참 좋은 선례를 보여주는 회사다)에서 받아 Ok 몇번 클릭으로 설치… 역시 설치는 윈도우 보다 훨씬 쉽다.

이것저것 설치하고 글꼴도 설정들도 조율하고, VGA 카드 드라이버도 설치하고..
이제 인터넷 뱅킹을 위해 VirtualBox 설치! 앗 그런데 인터넷 뱅킹에서 죽는다..
이것 저것 검색해보니 키보드 보안 모듈 때문이란다. 그런데 이상하다 젠투에서는 문제가 없었다.

그래서 버전을 확인해 보았더니 우분투 공식 저장소에서 제공하는 VirtualBox OSE 의 버전은 1.50 으로 젠투의 VirtualBox OSE 버전인 1.52보다 조금 낮았다. 혹시 이후 버전에서 개선되었기 때문인가 하여 1.52를 받아 볼까 검색해 보니 VirtualBox 공식 사이트에서 VirtualBox 의 우분투 패키지를 아예 제공해준다(어익후 감사). 더군다나 각 우분투 및 데비안 버전마다 저장소 까지 제공해 준다. 덕분에 간단히 설치를 끝냈고 현재 인터넷 뱅킹은 문제 없이 잘되는 중이다. 아무래도 해당 문제는 1.52 이상에서 발생되지 않도록 개선된듯.

문제 있는 분들(특히 뭐 선배님) 1.52 버전로 얼렁 바꾸세요!


Follow

Get every new post delivered to your Inbox.

Join 440 other followers